const regex = new RegExp('\\/\\/([^\\"]+?)$', 'gm')
const str = `// coment1
"//coment"
//coment2
console.log("//coment"); //coment3
myfunc("//coment");
//coment 1232dfs s d
somefunc1("//coment");
somefunc2("//coment");
//end comment
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}