#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(ZAR|R|)[-\$\d,.]+"
Local $sString = "R1236 or ZAR1,236.00 1236 witt $1236, 1,236.00 or 1236.00" & @CRLF & _
"" & @CRLF & _
"Total Amount Due -1234" & @CRLF & _
"Total -1234" & @CRLF & _
"Total Due -1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")