using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(ZAR|R|)[-\$\d,.]+";
string input = @"R1236 or ZAR1,236.00 1236 witt $1236, 1,236.00 or 1236.00
Total Amount Due -1234
Total -1234
Total Due -1234";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}