Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(ZAR|R|)[-\$\d,.]+
/
gm
Input 1
1
New
R1236 or ZAR1,236.00 1236 witt $1236, 1,236.00 or 1236.00 Total Amount Due -1234 Total -1234 Total Due -1234