$re = '/(ZAR|R|)[-\$\d,.]+/m';
$str = 'R1236 or ZAR1,236.00 1236 witt $1236, 1,236.00 or 1236.00
Total Amount Due -1234
Total -1234
Total Due -1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);