// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(ZAR|R|)[-\$\d,.]+").unwrap();
let string = "R1236 or ZAR1,236.00 1236 witt $1236, 1,236.00 or 1236.00
Total Amount Due -1234
Total -1234
Total Due -1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}