// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:[^`█]█*){1,23}[ ]").unwrap();
let string = "Now is the time for all good men to █come to the aid█ of the party. ";
let substitution = "$0\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}