import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<FirstPart>(?:<div>.*?){4}).*(?<SecondPart>(?:<\\/div>.*?){4})";
final String string = "<!DOCTYPE html>\n\n"
+ "<html>\n\n"
+ " <head>\n\n"
+ " </head>\n\n"
+ " <body>\n\n"
+ "<div>\n\n"
+ "<div>\n\n"
+ "<div>\n\n"
+ "<div>\n\n"
+ "<div>\n\n"
+ "<div>\n\n"
+ "<div>\n\n"
+ "<div>\n\n"
+ "</div>\n\n"
+ "</div>\n\n"
+ "</div>\n\n"
+ "</div>\n\n"
+ "</div>\n\n"
+ "</div>\n\n"
+ "</div>\n\n"
+ "</div>\n\n"
+ " </body>\n\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}