using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"12345679810";
string input = @"1
2
123
1234
12345679810";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}