const regex = /12345679810/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('12345679810', '')
const str = `1
2
123
1234
12345679810`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}