# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s+\d+$"
test_str = ("0 100 Continuity_PPMU_mV XSCI 140\n"
"1 100 Continuity_PPMU_mV XSCI 12\n"
"2 100 Continuity_PPMU_mV XSCI 76\n"
"3 100 Continuity_PPMU_mV XSCI 204\n"
"4 101 Continuity_PPMU_mV XSCO 139")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.