import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\p{L}\\s]*\\p{L})\\p{L}*";
final String string = "Aliquam ipsum ex, tempus ornare semper ac, varius vitae nibh.\n\n"
+ "Dumnezeu a zis: „Să fie o întindere între ape, și ea să despartă apele de ape";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}