const regex = /([^\p{L}\s]*\p{L})\p{L}*/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\p{L}\\s]*\\p{L})\\p{L}*', 'gu')
const str = `Aliquam ipsum ex, tempus ornare semper ac, varius vitae nibh.
Dumnezeu a zis: „Să fie o întindere între ape, și ea să despartă apele de ape`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);