re = /.*\/polygon\/all\/[0-9]*\.?[0-9]+\/[0-9]*\.?[0-9]+/m
str = 'http://gondor.ts.cynn.io:8087/polygon/all/55.23234/33.1983179237'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end