// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*\/polygon\/all\/[0-9]*\.?[0-9]+\/[0-9]*\.?[0-9]+").unwrap();
let string = "http://gondor.ts.cynn.io:8087/polygon/all/55.23234/33.1983179237";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}