package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\d+(?:_\d+)+\b`)
var str = `most popular data structure in OOP lists/5438_133195_9917949_1218833? povid=racking these benchmarks`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}