$re = '/\b\d+(?:_\d+)+\b/';
$str = 'most popular data structure in OOP lists/5438_133195_9917949_1218833? povid=racking these benchmarks';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);