const regex = /Field<([a-zA-Z]+)>\("([a-zA-Z]+)", null, nullable: true, null\);/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Field<([a-zA-Z]+)>\\("([a-zA-Z]+)", null, nullable: true, null\\);', 'gm')
const str = `Field<OrderByEnumType>("id", null, nullable: true, null);
Field<OrderType>("from_id", null, nullable: true, null);
`;
const subst = `Field(x => x.$2, nullable: true, type: typeof($1));`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);