// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)Field<([a-zA-Z]+)>\("([a-zA-Z]+)", null, nullable: true, null\);"#).unwrap();
let string = "Field<OrderByEnumType>(\"id\", null, nullable: true, null);
Field<OrderType>(\"from_id\", null, nullable: true, null);
";
let substitution = "Field(x => x.$2, nullable: true, type: typeof($1));";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}