import Foundation
let pattern = #"Field<([a-zA-Z]+)>\("([a-zA-Z]+)", null, nullable: true, null\);"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Field<OrderByEnumType>("id", null, nullable: true, null);
Field<OrderType>("from_id", null, nullable: true, null);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Field(x => x.$2, nullable: true, type: typeof($1));"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)