# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d\d(?:([.,])\d(?:\d(?:\1\d\d?|)|)|)(?: \d\d(?:([.,])\d(?:\d(?:\2\d\d?|)|)|))*$"
test_str = ("Нужно захватывать такие виды оквэдов (1 === \\d{1}):\n"
"11\n"
"11.1\n"
"11,1\n"
"11.11\n"
"11,11\n"
"11.11.1\n"
"11,11,1\n"
"11.11.11\n"
"11,11,11\n"
"11 11.11 11.11.11\n"
"11 11,11 11,11,11\n\n"
"Недопустимы:\n"
"11,11.11\n"
"11.11,11\n"
"11.1.11\n"
"11.1.1\n"
"11.\n"
"11,\n"
"11.1.\n"
"11,1,\n"
"11.11.\n"
"11,11,\n"
"11.11.1.\n"
"11,11,1,\n"
"11.11.11.\n"
"11,11,11,\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.