const regex = /(.*?)([[:alnum:]]+)(::)(.*?)|./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)([[:alnum:]]+)(::)(.*?)|.', 'gm')
const str = `library(ggplot2)
library(ggplot2, verbose = TRUE)
library(ggplot2, stringr)
library("ggplot2")
library("ggplot2", "yarrr")
require(stringr)
#' @import fields
#' @importFrom neotoma compile_taxa
neotoma::get_dataset()
dataset %>% dplyr::filter(value > 10) %>% DT::datatable()`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}