// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*?)([[:alnum:]]+)(::)(.*?)|.").unwrap();
let string = "library(ggplot2)
library(ggplot2, verbose = TRUE)
library(ggplot2, stringr)
library(\"ggplot2\")
library(\"ggplot2\", \"yarrr\")
require(stringr)
#' @import fields
#' @importFrom neotoma compile_taxa
neotoma::get_dataset()
dataset %>% dplyr::filter(value > 10) %>% DT::datatable()";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}