$re = '/[a-z]+((\d)|([A-Z0-9][a-z0-9]+))*([A-Z])?/';
$str = 'xmlHttpRequest
newCustomerId
innerStopwatch
supportsIpv6OnIos
youTubeImporter
youtubeImporter
affine3D
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);