use strict;
my $str = 'drupal_add_js(array(\'my_common\' => array(\'my_code_validate\' => variable_get(\'my_code_validate\', FALSE), \'inner_index2 => \'inner_value2\'), \'another_item\' => \'another_value\'), \'setting\');
\'my_common\' => array(\'my_code_validate\' => variable_get(\'my_code_validate\', FALSE), \'inner_index2 => \'inner_value2\'), \'another_item\' => \'another_value\'';
my $regex = qr/array(\(((?:[^()]++|(?1))*)\))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}