re = /([^"']*jquery[\-\d.]*\.min\.js[^"']*)/m
str = '"https://code.jquery.com/jquery-3.5.1.min.js?abc=1"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end