// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)([^"']*jquery[\-\d.]*\.min\.js[^"']*)"#).unwrap();
let string = "\"https://code.jquery.com/jquery-3.5.1.min.js?abc=1\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}