const regex = /^\W*?ENTRY\W*(?P<entries>(?>[ ]*? \d+ (?:[.,] \d+)? [ ]*?) - (?>[ ]*? \d+ (?:[.,] \d+)? [ ]*?) | (?>[ ]*? \d+ (?:[.,] \d+)? [ ]*?))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\W*?ENTRY\\W*(?P<entries>(?>[ ]*? \\d+ (?:[.,] \\d+)? [ ]*?) - (?>[ ]*? \\d+ (?:[.,] \\d+)? [ ]*?) | (?>[ ]*? \\d+ (?:[.,] \\d+)? [ ]*?))', 'gm')
const str = `ENTRY: 0.0975 - 0.101
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}