package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(&[^&=]+=)&`)
var str = `something=na&rows[0][data]=0&rows[0][name]=&rows[0][indexable]=true&rows[0][searchable]=false&columns[0][search][value]=&
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}