re = /(&[^&=]+=)&/m
str = 'something=na&rows[0][data]=0&rows[0][name]=&rows[0][indexable]=true&rows[0][searchable]=false&columns[0][search][value]=&
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end