const regex = new RegExp('^(?!ajax)(?!index\\.cfm)(.*?).cfm.*$', 'gm')
const str = `contact.cfm
contact.cfm?p=1
contact.cfm?p=cc.cfm
page.cfm
contact
index.cfm?p=contact
ajax/contact-form.cfm
index.cfm?p=contact.cfm
`;
const subst = `index.cfm?p=$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);