use strict;
my $str = 'contact.cfm
contact.cfm?p=1
contact.cfm?p=cc.cfm
page.cfm
contact
index.cfm?p=contact
ajax/contact-form.cfm
index.cfm?p=contact.cfm
';
my $regex = qr/^(?!ajax)(?!index\.cfm)(.*?).cfm.*$/mp;
my $subst = 'index.cfm?p=$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";