re = /src='([^']+)'\stext='([^']+)'\ssize=(\d+)/
str = 'src=\'http://...\' text=\'HELLO WORLD! More content\' size=55'
subst = '$1\\n$2\\n$3 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result