using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img[ .="":;a-zA-Z0-9]+(height:[ 0-9]+px)+";
string input = @"<div style=""height: 300px""><img src=""t.jpg"" style=""width:1000px; height: 300px""><img src=""t.jpg"" style=""width:1000px; height: 500px""><eee src=""t.jpg"" style=""width:1000px; height: 500px"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}