# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:NBCRCT\s+\d*\s+[\w\d]+\s+(\d+))(?:\s+[\s\w\-]+IDLE\s+[\w\-]+\s+(\d+))"
test_str = ("LOADING PROGRAM VERSION 11.21-0\n\n"
"MSCi MSSMCY01 2020-11-25 16:41:03\n\n"
" CGR NCGR NBCRCT\n"
" 1530 MY1VMS1A 124\n\n\n"
" STATE CONN COND NUMBER\n"
" BA-RC IDLE - 124\n\n"
"COMMAND EXECUTED\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.