Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
\b(?!\d)([ELX0-9-])\w{1,}
/
gm
Input 1
1
New
S-Buy BL460c G6 E5540 8G 2P Svr BL460c G6 X5550 6G 1P Svr BL460c G6 E5540 6G 1P Svr BL460c G6 E5540 6G 1P Svr BL460c G6 E5530 6G 1P Svr BL460c G6 L5520 6G 1P Svr BL460c G6 E5520 6G 1P Svr BL460c G6 E5506 6G 1P Svr BL460c G6 E5502 6G 1P Svr BL280c G6 L5520 2G LP 1P Svr BL280c G6 E5520 2G 1P Svr BL280c G6 E5540 2G 1P Svr BL280c G6 E5502 2G 1P Svr S-Buy BL460c G6 E5540 8G 2P Svr S-Buy BL460c G6 E5530 4G 1P Svr S-Buy BL460c G6 E5530 4G 1P Svr BL2x220c G6 E5540 24G 2P 250GB Svr BL2x220c G6 E5530 24G 2P 250GB Svr BL2x220c G6 L5530 24G 2P 250GB Svr BL2x220c G6 L5520 24G 2P BL2x220c G6 E5640 2x2P 24G Svr BL2x220c G6 E5630 2x2P 24G Svr BL2x220c G6 L5640 2x2P 24G Svr BL2x220c G6 Mod0 Svr BL280c G6 X5650 6G 1P Svr BL280c G6 E5630 4G 1P Svr BL280c G6 L5640 4G 1P Svr BL280c G6 E5506 2G 1P Svr BL620c G7 E7-2860 32G Svr BL620c G7 E7-2850 32G Svr BL620c G7 E7-2830 32G Svr BL680c G7 E7-4860 64G Svr BL680c G7 E7-4860 64G Svr BL680c G7 E7-4850 64G Svr BL680c G7 E7-4830 64G Svr