const regex = /^(?:19|20)?\d{2}(?!000|500|36[7-9]|3[7-9]\d|86[7-9]|8[7-9]\d)[0-35-8]\d\d\d{4}[vVxX]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:19|20)?\\d{2}(?!000|500|36[7-9]|3[7-9]\\d|86[7-9]|8[7-9]\\d)[0-35-8]\\d\\d\\d{4}[vVxX]$', 'gm')
const str = `Format should be
937962723V
or
937962723X
or any 11 digit number according to the current format.
19345678901x`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}