$re = '/FL\s?\d+/m';
$str = '" today I m at FL12, tomorrow I will be at FL 103
" today I m at FLb12, tomorrow I will be at FL a123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);