$re = '/myArray(\[.+?])(\[.+?]\[.+?])(\[.+?])/m';
$str = 'myArray[a][...][...][b]';
$subst = "myArray$3$2$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;