#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?=(\d{2}$)+(?!\d))"
Local $sString = "11,11" & @CRLF & _
"00,00" & @CRLF & _
"20,20" & @CRLF & _
"20.20" & @CRLF & _
"30.233" & @CRLF & _
"1000000000000000" & @CRLF & _
"123123" & @CRLF & _
"12432"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)