using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(\d{2}$)+(?!\d))";
string substitution = @"";
string input = @"11,11
00,00
20,20
20.20
30.233
1000000000000000
123123
12432";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}