using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\,(?=\s*?[\}\]])";
string input = @"[
{
""ITEM1"":{
""names"":[
""nameA"",
]
}
},
{
""ITEM2"":{
""names"":[
""nameB"",
""nameC"",
],
""linear"": [""nameD"", ""nameE"", ],
""chars"": ""a, b, c,""
}
},
]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}