const regex = /\,(?=\s*?[\}\]])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\,(?=\\s*?[\\}\\]])', 'g')
const str = `[
{
"ITEM1":{
"names":[
"nameA",
]
}
},
{
"ITEM2":{
"names":[
"nameB",
"nameC",
],
"linear": ["nameD", "nameE", ],
"chars": "a, b, c,"
}
},
]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}