# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"*(\d+)"*/"\1"/gm;t' <<< "111
222
333
444 555
\"111\", 222
777
\"\"111
111\"\"\"
\"ab111\""