using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""*(\d+)""*";
string substitution = @"""\1""";
string input = @"111
222
333
444 555
""111"", 222
777
""111
111""""
""ab111""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}