$re = '/_([^_]+)(_[^_]*){3}$/m';
$str = 'channel_product_country_medium_brand_offer_campaignname_ctatext_date_objective_0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);