#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{2,6}$)([a-z]+[0-9]*)$"
Local $sString = "a1" & @CRLF & _
"abc12" & @CRLF & _
"ab123" & @CRLF & _
"abcd1" & @CRLF & _
"abcd" & @CRLF & _
"abcde" & @CRLF & _
"abcdef" & @CRLF & _
"abcdefg" & @CRLF & _
"abcde1" & @CRLF & _
"abcde12" & @CRLF & _
"" & @CRLF & _
"#aaaa" & @CRLF & _
"a#2" & @CRLF & _
"a" & @CRLF & _
"" & @CRLF & _
"1abc" & @CRLF & _
"123456" & @CRLF & _
"ab23c" & @CRLF & _
"" & @CRLF & _
"a1b2c1" & @CRLF & _
"a12345" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")