import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{2,6}$)([a-z]+[0-9]*)$";
final String string = "a1\n"
+ "abc12\n"
+ "ab123\n"
+ "abcd1\n"
+ "abcd\n"
+ "abcde\n"
+ "abcdef\n"
+ "abcdefg\n"
+ "abcde1\n"
+ "abcde12\n\n"
+ "#aaaa\n"
+ "a#2\n"
+ "a\n\n"
+ "1abc\n"
+ "123456\n"
+ "ab23c\n\n"
+ "a1b2c1\n"
+ "a12345\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}