import Foundation
let pattern = #"^((?:\d{6})(?:(?:,[^\n]\d{6}){1,})?)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
123456
123456, 456789, 987654
1
,
123456, 123456, 987654,
123456, 123456
123456, 456789, 987654, 123456, 1234567
123456, 456789, 987654, 123456, 123456, 345678
1,
,
,
123,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)