#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/(?:(?:(?:www\.)?youtu(?:(?:be\.(?:com|nl|it|co\.nz|com\.br|de|es|ru))|(?:be-nocookie\.com))\/(?:(?:watch\?v=)|(?:v\/)|(?:embed\/)))|(?:youtu\.be\/))(?<video_id>[a-zA-Z0-9\-_]{11})(?:[a-zA-Z0-9\-_\?=&%\.]+)?$"
Local $sString = "https://www.youtube.com/watch?v=Cf_4WmACpws" & @CRLF & _
"https://www.youtube.com/watch?v=oXXiJx7kaeE" & @CRLF & _
"https://youtu.be/Cf_4WmACpws?t=6879" & @CRLF & _
"https://www.youtube.com/watch?v=xYXV-SysdLw" & @CRLF & _
"https://www.youtube.nl/watch?v=xYXV-SysdLw" & @CRLF & _
"https://youtu.be/xYXV-SysdLw" & @CRLF & _
"https://www.youtube.com/channel/UClgRkhTL3_hImCAmdLfDE4g" & @CRLF & _
"https://www.youtube.com/feed/trending" & @CRLF & _
"https://youtu.be/YV-5SqpjBII&derp=%3Dhttps.comsfsdf" & @CRLF & _
"https://www.youtube.com/watch?v=6E3MMKzBn1g" & @CRLF & _
"https://www.youtube.com/feed/history" & @CRLF & _
"http://www.youtube.com/playlist?list=WL" & @CRLF & _
"https://www.youtube.com/watch?v=0f1cRNmQHVE" & @CRLF & _
"https://www.youtube.com/playlist?list=PLK8KId9LS-dRgDGDNLgMqBRXlwbUAuF0s" & @CRLF & _
"https://www.youtube.com/channel/UCFbNIlppjAuEX4znoulh0Cw" & @CRLF & _
"https://www.youtube.com/embed/M7lc1UVf-VE" & @CRLF & _
"http://www.youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare" & @CRLF & _
"https://www.youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail" & @CRLF & _
"http://www.youtube.com/watch?v=-wtIMTCHWuI" & @CRLF & _
"http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1" & @CRLF & _
"http://youtu.be/-wtIMTCHWuI" & @CRLF & _
"http://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json" & @CRLF & _
"http://s.ytimg.com/yt/favicon-wtIMTCHWuI.ico" & @CRLF & _
"http://i2.ytimg.com/vi/-wtIMTCHWuI/hqdefault.jpg" & @CRLF & _
"https://www.youtube-nocookie.com/watch?v=Cf_4WmACpws" & @CRLF & _
"https://www.youtube.com/watch?v=inu0xeteuxg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")